<!DOCTYPE html>
<html lang="en-US">
<head >
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1" />
<title>Guns and Drugs Seized in Arrests at St. Pete House</title>
<meta name='robots' content='max-image-preview:large' />
<link rel='dns-prefetch' href='//js.stripe.com' />
<link rel='dns-prefetch' href='//www.googletagmanager.com' />
<link rel='dns-prefetch' href='//checkout.stripe.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Gabber Newspaper &raquo; Feed" href="https://thegabber.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Gabber Newspaper &raquo; Comments Feed" href="https://thegabber.com/comments/feed/" />
<link rel="alternate" type="text/calendar" title="The Gabber Newspaper &raquo; iCal Feed" href="https://thegabber.com/events/?ical=1" />
<link rel="canonical" href="https://thegabber.com/guns-and-drugs-seized-in-arrests-at-st-pete-house/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/thegabber.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.7"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='tribe-common-skeleton-style-css'  href='https://thegabber.com/wp-content/plugins/the-events-calendar/common/src/resources/css/common-skeleton.min.css?ver=4.12.18' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-tooltip-css'  href='https://thegabber.com/wp-content/plugins/the-events-calendar/common/src/resources/css/tooltip.min.css?ver=4.12.18' type='text/css' media='all' />
<link rel='stylesheet' id='eleven40-pro-css'  href='https://thegabber.com/wp-content/themes/eleven40-pro/style.css?ver=2.2.3' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://thegabber.com/wp-includes/css/dist/block-library/style.min.css?ver=5.7' type='text/css' media='all' />
<link rel='stylesheet' id='stripe-checkout-button-css'  href='https://checkout.stripe.com/v3/checkout/button.css' type='text/css' media='all' />
<link rel='stylesheet' id='simpay-public-css'  href='https://thegabber.com/wp-content/plugins/wp-simple-pay-pro-3/includes/core/assets/css/simpay-public.min.css?ver=4.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='simpay-jquery-ui-cupertino-css'  href='https://thegabber.com/wp-content/plugins/wp-simple-pay-pro-3/includes/pro/assets/css/vendor/jquery-ui/jquery-ui-cupertino.min.css?ver=4.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='simpay-public-pro-css'  href='https://thegabber.com/wp-content/plugins/wp-simple-pay-pro-3/includes/pro/assets/css/simpay-public-pro.min.css?ver=4.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://thegabber.com/wp-includes/css/dashicons.min.css?ver=5.7' type='text/css' media='all' />
<link rel='stylesheet' id='gabber-google-css'  href='//fonts.googleapis.com/css2?family=Oswald%3Awght%40500%3B600&#038;display=swap&#038;ver=0.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='gabber-setup-core-css'  href='https://thegabber.com/wp-content/plugins/gabber-setup-core/assets/css/gabber-setup-core.min.css?ver=0.1.1' type='text/css' media='all' />
<script type='text/javascript' src='https://thegabber.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' src='https://thegabber.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://thegabber.com/wp-content/plugins/zero-bs-crm/js/ZeroBSCRM.public.global.min.js?ver=4.0.14' id='zerobscrmglob-js'></script>
<script type='text/javascript' src='https://thegabber.com/wp-content/themes/eleven40-pro/js/responsive-menu.js?ver=1.0.0' id='eleven40-responsive-menu-js'></script>
<script type='text/javascript' src='https://www.googletagmanager.com/gtag/js?id=UA-167451684-1' id='google_gtagjs-js' async></script>
<script type='text/javascript' id='google_gtagjs-js-after'>
window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}
gtag("js", new Date());
gtag("set", "developer_id.dZTNiMT", true);
gtag("config", "UA-167451684-1", {"anonymize_ip":true});
</script>
<link rel="https://api.w.org/" href="https://thegabber.com/wp-json/" /><link rel="alternate" type="application/json" href="https://thegabber.com/wp-json/wp/v2/posts/60814" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://thegabber.com/xmlrpc.php?rsd" />
<link rel="alternate" type="application/json+oembed" href="https://thegabber.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fthegabber.com%2Fguns-and-drugs-seized-in-arrests-at-st-pete-house%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://thegabber.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fthegabber.com%2Fguns-and-drugs-seized-in-arrests-at-st-pete-house%2F&#038;format=xml" />
<link rel="apple-touch-icon" sizes="180x180" href="https://thegabber.com/wp-content/plugins/gabber-setup-core/assets/img/favicons/apple-touch-icon.png">
<link rel="icon" type="image/png" sizes="32x32" href="https://thegabber.com/wp-content/plugins/gabber-setup-core/assets/img/favicons/favicon-32x32.png">
<link rel="icon" type="image/png" sizes="16x16" href="https://thegabber.com/wp-content/plugins/gabber-setup-core/assets/img/favicons/favicon-16x16.png">
<link rel="manifest" href="https://thegabber.com/wp-content/plugins/gabber-setup-core/assets/img/favicons/site.webmanifest">
<link rel="mask-icon" href="https://thegabber.com/wp-content/plugins/gabber-setup-core/assets/img/favicons/safari-pinned-tab.svg" color="#5bbad5">
<meta name="msapplication-TileColor" content="#da532c">
<meta name="theme-color" content="#ffffff">
<meta name="generator" content="Site Kit by Google 1.28.0" /><meta property="og:title" content="Guns and Drugs Seized in Arrests at St. Pete House" />
<meta name="description" content="St. Petersburg Police made the bust on a house that had 221 service calls since December, nabbing handguns, cash, cocaine, crack and heroin." />
<meta property="og:description" content="St. Petersburg Police made the bust on a house that had 221 service calls since December, nabbing handguns, cash, cocaine, crack and heroin." />
<meta property="og:image" content="https://thegabber.com/wp-content/uploads/2021/04/Drug-Bust-Guns_St.-Peteraburg-Police-Department-scaled.jpg" />
<meta name="twitter:card" content="summary" />
<meta property="og:url" content="https://thegabber.com/guns-and-drugs-seized-in-arrests-at-st-pete-house/" />
<meta name="viewport" content="width=device-width, initial-scale=1" /><meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://thegabber.com"><link rel="https://theeventscalendar.com/" href="https://thegabber.com/wp-json/tribe/events/v1/" /><link rel="icon" href="https://thegabber.com/wp-content/themes/eleven40-pro/images/favicon.ico" />
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><script>(adsbygoogle = window.adsbygoogle || []).push({"google_ad_client":"ca-pub-6591356991661880","enable_page_level_ads":true,"tag_partner":"site_kit"});</script></head>
<body class="post-template-default single single-post postid-60814 gabber-customs gabber-inner-content-body tribe-no-js page-template-home-wp_jhba6j-thegabber-com-wp-content-themes-genesis-page-php tribe-theme-parent-genesis tribe-theme-child-eleven40-pro header-full-width content-sidebar genesis-breadcrumbs-hidden genesis-footer-widgets-visible eleven40-pro-blue" itemscope itemtype="https://schema.org/WebPage"><div class="site-container"><ul class="genesis-skip-link"><li><a href="#genesis-nav-primary" class="screen-reader-shortcut"> Skip to primary navigation</a></li><li><a href="#genesis-content" class="screen-reader-shortcut"> Skip to main content</a></li><li><a href="#genesis-sidebar-primary" class="screen-reader-shortcut"> Skip to primary sidebar</a></li><li><a href="#genesis-footer-widgets" class="screen-reader-shortcut"> Skip to footer</a></li></ul><header class="site-header" itemscope itemtype="https://schema.org/WPHeader"><div class="wrap"><nav class="nav-primary" aria-label="Main" itemscope itemtype="https://schema.org/SiteNavigationElement" id="genesis-nav-primary"><div class="wrap"><ul id="menu-top-bar-menu" class="menu genesis-nav-menu menu-primary js-superfish"><li id="menu-item-59036" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-59036"><a href="https://thegabber.com/about-the-gabber/" itemprop="url"><span itemprop="name">About the Gabber</span></a></li>
<li id="menu-item-1680" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1680"><a href="https://thegabber.com/contact-us/" itemprop="url"><span itemprop="name">Contact</span></a></li>
<li id="menu-item-53724" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-53724"><a href="https://thegabber.com/get-your-gabber/" itemprop="url"><span itemprop="name">Get your Gabber</span></a></li>
<li id="menu-item-53928" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-53928"><a href="https://thegabber.com/save-the-gabber/" itemprop="url"><span itemprop="name">Support the Gabber!</span></a></li>
<li id="menu-item-src-soc" class="menu-item gabber-topline-menu-item gabber-topline-search-menu-item"><span class="gabber-topline-item-set gabber-topline-social-menu-links"><span class="gabber-social-link-single gabber-social-link-facebook"><a href="https://www.facebook.com/GabberNews" title=""><i class="dashicons dashicons-facebook"></i></a></span><span class="gabber-social-link-single gabber-social-link-twitter"><a href="https://twitter.com/GabberNews" title=""><i class="dashicons dashicons-twitter"></i></a></span><span class="gabber-social-link-single gabber-social-link-instagram"><a href="https://www.instagram.com/gabberlife/" title=""><i class="dashicons dashicons-instagram"></i></a></span><span class="gabber-social-link-single gabber-social-link-youtube"><a href="https://www.youtube.com/channel/UCG-SkhTpcP3YYGCeFfcizIA" title=""><i class="dashicons dashicons-video-alt3"></i></a></span></span><span class="gabber-topline-item-set gabber-topline-search-menu-form"><form class="search-form" method="get" action="https://thegabber.com/" role="search" itemprop="potentialAction" itemscope itemtype="https://schema.org/SearchAction"><label class="search-form-label screen-reader-text" for="searchform-1">Search this website</label><input class="search-form-input" type="search" name="s" id="searchform-1" placeholder="Search this website" itemprop="query-input"><input class="search-form-submit" type="submit" value="Search"><meta content="https://thegabber.com/?s={s}" itemprop="target"></form></span></li></ul></div></nav></div></header><div class="site-inner"><div class="wrap"><div class="logo-top-banner-wrap"><div class="top-item-block top-logo-block"><div class="top-logo-block-wrap"><a href="https://thegabber.com"><img src="https://thegabber.com/wp-content/plugins/gabber-setup-core/assets/img/gabber-logo-web.png"></a></div></div><div class="top-item-block top-gabber-banner-block"><div class="single-gabber-ad single-gabber-banner-ad top-gabber-ad-block"><a class="single-gabber-ad-link" target="_blank" rel="noopener" href="https://lifeplanlaw.com/event/how-does-a-will-or-trust-work-by-catherine-e-blackburn/"><img class="single-gabber-ad-image" src="https://thegabber.com/wp-content/uploads/2021/04/040821-web-728x90.jpg"></a></div></div></div><div class="top-content-nav-menu"><div class="wrap top-content-outer-nav-wrap"><nav id="top-content-nav" class="nav-primary menu-new-top-content-container"><div class="wrap top-content-inner-nav-wrap"><ul id="menu-primary-menu" class="menu genesis-nav-menu menu-primary top-content-nav-menu-wrap js-superfish responsive-menu sf-js-enabled sf-arrows"><li id="menu-item-53381" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-53381"><a href="https://thegabber.com/category/news/" itemprop="url">News</a>
<ul class="sub-menu">
	<li id="menu-item-54583" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54583"><a href="https://thegabber.com/category/vote/" itemprop="url">Vote</a></li>
</ul>
</li>
<li id="menu-item-53379" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-53379"><a href="https://thegabber.com/category/arts/" itemprop="url">Arts</a></li>
<li id="menu-item-53380" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-53380"><a href="https://thegabber.com/category/food/" itemprop="url">Food</a></li>
<li id="menu-item-53931" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-53931"><a title="#" href="https://thegabber.com/lifestyle/" itemprop="url">Lifestyle</a>
<ul class="sub-menu">
	<li id="menu-item-53932" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-53932"><a href="https://www.youtube.com/channel/UCG-SkhTpcP3YYGCeFfcizIA" itemprop="url">The Gabs</a></li>
	<li id="menu-item-54578" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54578"><a href="https://thegabber.com/category/adopt-a-pet/" itemprop="url">Adopt A Pet</a></li>
	<li id="menu-item-54579" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54579"><a href="https://thegabber.com/category/voices/" itemprop="url">Voices</a></li>
	<li id="menu-item-54072" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54072"><a href="https://thegabber.com/category/take-the-gabber/" itemprop="url">Take the Gabber</a></li>
	<li id="menu-item-54357" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54357"><a href="https://www.legacy.com/obituaries/thegabber/" itemprop="url">Obituaries</a></li>
</ul>
</li>
<li id="menu-item-53386" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-53386"><a href="https://thegabber.com/events" itemprop="url">Events</a>
<ul class="sub-menu">
	<li id="menu-item-53387" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-53387"><a href="https://thegabber.com/events" itemprop="url">View All Events</a></li>
	<li id="menu-item-53388" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-53388"><a href="https://thegabber.com/events/community/add" itemprop="url">Add Your Event</a></li>
</ul>
</li>
<li id="menu-item-53382" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-53382"><a href="https://thegabber.com/classifieds/" itemprop="url">Classified Ads</a>
<ul class="sub-menu">
	<li id="menu-item-53383" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-53383"><a href="https://thegabber.com/classifieds/" itemprop="url">View Classifieds</a></li>
	<li id="menu-item-53384" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-53384"><a href="https://thegabber.com/purchase-a-classified/" itemprop="url">Purchase A Classified</a></li>
</ul>
</li>
<li id="menu-item-53615" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-53615"><a href="https://thegabber.com/current-issue/" itemprop="url">Current Issue</a></li>
</ul></div></nav></div></div><div class="content-sidebar-wrap"><main class="content" id="genesis-content"><article class="post-60814 post type-post status-publish has-post-thumbnail category-news tag-st-petersburg-drug-house-bust tag-st-petersburg-police tag-st-petersburg-police-gun-drug-arrests single-post-page-entry entry" aria-label="Guns and Drugs Seized in Arrests at St. Pete House" itemscope itemtype="https://schema.org/CreativeWork"><header class="entry-header"><h1 class="entry-title" itemprop="headline">Guns and Drugs Seized in Arrests at St. Pete House</h1>
<p class="entry-meta"><time class="entry-time" itemprop="datePublished" datetime="2021-04-09T14:57:44-04:00">April 9, 2021</time> by <span class="entry-author" itemprop="author" itemscope itemtype="https://schema.org/Person"><span class="entry-author-name" itemprop="name">The Gabber</span></span></p></header><div class="entry-content" itemprop="text"><figure id="attachment_60815" aria-describedby="caption-attachment-60815" style="width: 2560px" class="wp-caption alignnone"><img loading="lazy" class="size-full wp-image-60815" src="https://thegabber.com/wp-content/uploads/2021/04/Drug-Bust-Guns_St.-Peteraburg-Police-Department-scaled.jpg" alt="Multiple handguns and ammunition laid out of a brown surface. " width="2560" height="1434" srcset="https://thegabber.com/wp-content/uploads/2021/04/Drug-Bust-Guns_St.-Peteraburg-Police-Department-scaled.jpg 2560w, https://thegabber.com/wp-content/uploads/2021/04/Drug-Bust-Guns_St.-Peteraburg-Police-Department-300x168.jpg 300w, https://thegabber.com/wp-content/uploads/2021/04/Drug-Bust-Guns_St.-Peteraburg-Police-Department-1024x573.jpg 1024w, https://thegabber.com/wp-content/uploads/2021/04/Drug-Bust-Guns_St.-Peteraburg-Police-Department-768x430.jpg 768w, https://thegabber.com/wp-content/uploads/2021/04/Drug-Bust-Guns_St.-Peteraburg-Police-Department-1536x860.jpg 1536w, https://thegabber.com/wp-content/uploads/2021/04/Drug-Bust-Guns_St.-Peteraburg-Police-Department-2048x1147.jpg 2048w, https://thegabber.com/wp-content/uploads/2021/04/Drug-Bust-Guns_St.-Peteraburg-Police-Department-340x190.jpg 340w, https://thegabber.com/wp-content/uploads/2021/04/Drug-Bust-Guns_St.-Peteraburg-Police-Department-640x360.jpg 640w" sizes="(max-width: 2560px) 100vw, 2560px" /><figcaption id="caption-attachment-60815" class="wp-caption-text">Guns confiscated in the bust. Photo courtesy of the St. Peteraburg Police Department.</figcaption></figure>
<hr />
<p><span style="font-weight: 400;">Since December of 2020, St. Petersburg Police received 221 calls for service or complaints about a house at </span><span style="font-weight: 400;">900 40th St. S. According to police, detectives have also noted “a great deal of traffic in and out of the house with numerous guns in plain view.”</span></p>
<p><span style="font-weight: 400;">On Thursday, April 9 at 12:30 p.m., officers entered the property with a search warrant for weapons. They confiscated six guns (two of which were confirmed stolen), 48.8 grams of heroin (considered a “trafficking amount”), 18 grams of cocaine, 2.6 pounds of marijuana, oxycodone and more than $10,000 in cash. </span></p>
<p><span style="font-weight: 400;">Officers arrested Donte Williams, 25, for trafficking in heroin, possession of controlled substances (cocaine and crack cocaine), fleeing and eluding, DWLSR habitual offender (</span><span style="font-weight: 400;">Driving While License Suspended, Revoked or Cancelled)</span><span style="font-weight: 400;"> and for an existing warrant for the sale of heroin. Police also arrested Russel Jones, 26, for possession of a controlled substance (heroin); Andrew Manuel, 26, for possession of oxycodone; Raynardo Griffin, 28, who had four existing warrants for his arrest; and Kendra King, 31, as a felon in possession of a firearm (this was her home, according to police), and child neglect.</span></p>
<p><span style="font-weight: 400;">As officers were finishing at the house, a 16-year-old drove up to the house in a stolen vehicle. He was charged with auto theft, possession of ammunition, and violation of probation for prior vehicle theft.</span></p>
<p><span style="font-weight: 400;">Additional charges are pending. The investigation is ongoing. </span></p>
<p>&nbsp;</p>
</div><div class="after-content-gabber-author-box"><div class="gabber-author-box-block gabber-author-box-image-block"><img class="gabber-author-box-image" src="https://thegabber.com/wp-content/uploads/2020/07/favicon-80x80.jpg"></div><div class="gabber-author-box-block gabber-author-box-text-block"><p class="gabber-author-box-field gabber-author-box-name-field"><a href="mailto:&#80;&#117;&#98;&#108;&#105;&#115;h&#101;&#114;&#64;&#116;h&#101;gabbe&#114;&#46;&#99;&#111;&#109;">by The Gabber</a></p><ul class="gabber-author-box-social-list"><li class="gabber-author-box-field gabber-author-box-social-field gabber-author-box-facebook-field"><a href="https://www.facebook.com/GabberNews">/GabberNews</a></li><li class="gabber-author-box-field gabber-author-box-social-field gabber-author-box-twitter-field"><a href="https://twitter.com/GabberNews">/GabberNews</a></li><li class="gabber-author-box-field gabber-author-box-social-field gabber-author-box-instagram-field"><a href="https://www.instagram.com/gabberlife">/gabberlife</a></li></ul></div></div><div class="after-content-cta-wrap after-content-save-gabber"><p class="after-content-cta-item-wrap after-content-cta-button-wrap"><a class="after-content-cta-button button" target="_blank" href="https://checkout.square.site/buy/LJKLZCFXF2GWAKILBTSLDSML">Support the Gabber</a></p><p class="after-content-cta-item-wrap after-content-cta-content-wrap">Team Gabber brought back the print version of the newspaper, and we've redesigned our website to make it easier for you to get the news. We're not out of the woods yet, and every little bit helps pay our reporters, printer, and other expenses. Support local news and families — donate now to keep The Gabber Newspaper serving the community it loves!</p><h5 class="after-content-cta-item-wrap after-content-cta-subtitle-wrap">Please support local news and The Gabber Newspaper!</h5></div><footer class="entry-footer"><p class="entry-meta"><span class="entry-categories">Filed Under: <a href="https://thegabber.com/category/news/" rel="category tag">News</a></span> <span class="entry-tags">Tagged With: <a href="https://thegabber.com/tag/st-petersburg-drug-house-bust/" rel="tag">St. Petersburg Drug House Bust</a>, <a href="https://thegabber.com/tag/st-petersburg-police/" rel="tag">St. Petersburg Police</a>, <a href="https://thegabber.com/tag/st-petersburg-police-gun-drug-arrests/" rel="tag">St. Petersburg Police Gun Drug Arrests</a></span></p></footer></article></main><aside class="sidebar sidebar-primary widget-area" role="complementary" aria-label="Primary Sidebar" itemscope itemtype="https://schema.org/WPSideBar" id="genesis-sidebar-primary"><h2 class="genesis-sidebar-title screen-reader-text">Primary Sidebar</h2><section id="single-gabber-ad-widget-4" class="widget single-gabber-ad-widget-wrap"><div class="widget-wrap"><div class="single-gabber-ad single-gabber-scoreboard-ad"><a class="single-gabber-ad-link" target="_blank" rel="noopener" href="http://www.moralesburke.com"><img class="single-gabber-ad-image" src="https://thegabber.com/wp-content/uploads/2021/01/morales-burke-WEBSCORE-012821-300x250.jpg"></a></div></div></section>
<section id="media_image-10" class="widget widget_media_image"><div class="widget-wrap"><h3 class="widgettitle widget-title">Crossword</h3>
<a href="https://thegabber.com/play-crosswords/"><img width="300" height="300" src="https://thegabber.com/wp-content/uploads/crossword-300x300.jpeg" class="image wp-image-53391  attachment-medium size-medium" alt="" loading="lazy" style="max-width: 100%; height: auto;" srcset="https://thegabber.com/wp-content/uploads/crossword-300x300.jpeg 300w, https://thegabber.com/wp-content/uploads/crossword-1024x1024.jpeg 1024w, https://thegabber.com/wp-content/uploads/crossword-150x150.jpeg 150w, https://thegabber.com/wp-content/uploads/crossword-768x768.jpeg 768w, https://thegabber.com/wp-content/uploads/crossword-1536x1536.jpeg 1536w, https://thegabber.com/wp-content/uploads/crossword-2048x2048.jpeg 2048w, https://thegabber.com/wp-content/uploads/crossword-80x80.jpeg 80w" sizes="(max-width: 300px) 100vw, 300px" /></a></div></section>
<section id="single-gabber-ad-widget-5" class="widget single-gabber-ad-widget-wrap"><div class="widget-wrap"><div class="single-gabber-ad single-gabber-skyscraper-ad"><a class="single-gabber-ad-link" target="_blank" rel="noopener" href="http://www.moralesburke.com"><img class="single-gabber-ad-image" src="https://thegabber.com/wp-content/uploads/2021/01/morales-burke-WEBSKY-0128212-160x600.jpg"></a></div></div></section>
<section id="media_image-11" class="widget widget_media_image"><div class="widget-wrap"><h3 class="widgettitle widget-title">Sudoku</h3>
<a href="https://thegabber.com/play-sudoku/"><img width="300" height="300" src="https://thegabber.com/wp-content/uploads/sudoku-300x300.png" class="image wp-image-53392  attachment-medium size-medium" alt="" loading="lazy" style="max-width: 100%; height: auto;" srcset="https://thegabber.com/wp-content/uploads/sudoku-300x300.png 300w, https://thegabber.com/wp-content/uploads/sudoku-1024x1024.png 1024w, https://thegabber.com/wp-content/uploads/sudoku-150x150.png 150w, https://thegabber.com/wp-content/uploads/sudoku-768x768.png 768w, https://thegabber.com/wp-content/uploads/sudoku-1536x1536.png 1536w, https://thegabber.com/wp-content/uploads/sudoku-80x80.png 80w, https://thegabber.com/wp-content/uploads/sudoku.png 1920w" sizes="(max-width: 300px) 100vw, 300px" /></a></div></section>
<section id="single-gabber-ad-widget-6" class="widget single-gabber-ad-widget-wrap"><div class="widget-wrap"><div class="single-gabber-ad single-gabber-monster-ad"><a class="single-gabber-ad-link" target="_blank" rel="noopener" href="https://www.stormfitter.com/"><img class="single-gabber-ad-image" src="https://thegabber.com/wp-content/uploads/2021/04/stormfitters-Web-040821-monster-300x600.png"></a></div></div></section>
</aside></div><div class="gabber-footer-leaderboard-wrap clearfix"></div></div></div><footer class="site-footer" itemscope itemtype="https://schema.org/WPFooter"><div class="wrap"><p class="gabber-footer-copyright">&copy; 2021 All Rights Reserved | The Gabber Newspaper</p></div></footer></div>		<script>
		( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );
		</script>
		<script> /* <![CDATA[ */var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};/* ]]> */ </script><script type='text/javascript' src='https://js.stripe.com/v3/' id='sandhills-stripe-js-v3-js'></script>
<script type='text/javascript' src='https://thegabber.com/wp-content/plugins/wp-simple-pay-pro-3/includes/core/assets/js/simpay-polyfill.min.js?ver=4.0.2' id='simpay-polyfill-js'></script>
<script type='text/javascript' src='https://thegabber.com/wp-content/plugins/wp-simple-pay-pro-3/includes/core/assets/js/vendor/accounting.min.js?ver=4.0.2' id='simpay-accounting-js'></script>
<script type='text/javascript' id='simpay-shared-js-extra'>
/* <![CDATA[ */
var spGeneral = {"strings":{"currency":"USD","currencySymbol":"$","currencyPosition":"left","decimalSeparator":".","thousandSeparator":",","ajaxurl":"https:\/\/thegabber.com\/wp-admin\/admin-ajax.php"},"booleans":{"isTestMode":false,"isZeroDecimal":false,"scriptDebug":false},"i18n":{"mediaTitle":"Insert Media","mediaButtonText":"Use Image","couponPercentOffText":"% off","couponAmountOffText":"off"},"integers":{"decimalPlaces":2,"minAmount":1}};
/* ]]> */
</script>
<script type='text/javascript' src='https://thegabber.com/wp-content/plugins/wp-simple-pay-pro-3/includes/core/assets/js/simpay-public-shared.min.js?ver=4.0.2' id='simpay-shared-js'></script>
<script src='https://thegabber.com/wp-content/plugins/the-events-calendar/common/src/resources/js/underscore-before.js'></script>
<script type='text/javascript' src='https://thegabber.com/wp-includes/js/underscore.min.js?ver=1.8.3' id='underscore-js'></script>
<script src='https://thegabber.com/wp-content/plugins/the-events-calendar/common/src/resources/js/underscore-after.js'></script>
<script type='text/javascript' src='https://thegabber.com/wp-includes/js/backbone.min.js?ver=1.4.0' id='backbone-js'></script>
<script type='text/javascript' id='wp-api-request-js-extra'>
/* <![CDATA[ */
var wpApiSettings = {"root":"https:\/\/thegabber.com\/wp-json\/","nonce":"a9b7c4d2ec","versionString":"wp\/v2\/"};
/* ]]> */
</script>
<script type='text/javascript' src='https://thegabber.com/wp-includes/js/api-request.min.js?ver=5.7' id='wp-api-request-js'></script>
<script type='text/javascript' src='https://thegabber.com/wp-includes/js/wp-api.min.js?ver=5.7' id='wp-api-js'></script>
<script type='text/javascript' id='simpay-public-js-extra'>
/* <![CDATA[ */
var simplePayForms = [];
/* ]]> */
</script>
<script type='text/javascript' src='https://thegabber.com/wp-content/plugins/wp-simple-pay-pro-3/includes/core/assets/js/simpay-public.min.js?ver=4.0.2' id='simpay-public-js'></script>
<script type='text/javascript' src='https://thegabber.com/wp-content/plugins/wp-simple-pay-pro-3/includes/pro/assets/js/simpay-public-pro.min.js?ver=4.0.2' id='simpay-public-pro-js'></script>
<script type='text/javascript' src='https://thegabber.com/wp-includes/js/hoverIntent.min.js?ver=1.8.1' id='hoverIntent-js'></script>
<script type='text/javascript' src='https://thegabber.com/wp-content/themes/genesis/lib/js/menu/superfish.min.js?ver=1.7.10' id='superfish-js'></script>
<script type='text/javascript' src='https://thegabber.com/wp-content/themes/genesis/lib/js/menu/superfish.args.min.js?ver=3.3.3' id='superfish-args-js'></script>
<script type='text/javascript' src='https://thegabber.com/wp-content/themes/genesis/lib/js/skip-links.min.js?ver=3.3.3' id='skip-links-js'></script>
<script type='text/javascript' id='gabber-setup-core-js-extra'>
/* <![CDATA[ */
var GabberSetupCore = {"titleCount":"7","textCount":"40"};
/* ]]> */
</script>
<script type='text/javascript' src='https://thegabber.com/wp-content/plugins/gabber-setup-core/assets/js/gabber-setup-core.min.js?ver=0.1.1' id='gabber-setup-core-js'></script>
<script type='text/javascript' src='https://thegabber.com/wp-includes/js/wp-embed.min.js?ver=5.7' id='wp-embed-js'></script>
</body></html>
